Script Library

Order by
Showing controlup scripts that tagged 'citrix gateway, hardware, user details, vulnerability' ordered by Date

Check for Citrix ADC CVE-2019-19781 Vulnerability mitigation 2.2.9

this Script Action checks if the suggested mitigation responder policy is configured and globally bound on the Citrix ADC or Citrix Gateway appliance as described in Citrix knowledgebase article CTX267679 (https://support.citrix.com/article/CTX267679). Note: This Script Action does not perform the suggested mitigation for the management interfaces as it may break administration access. tags:NetScalers, Citrix ADC, Citrix Gateway, Vulnerability, Mitigation,
Created: 2020-01-01
Modified: 2020-01-08
Creator: ebarthel
Downloads: 85

Show computer CPU details 1.4.7

This script returns the details of the target machine CPU(s) as reported by the OS via WMI, including properties like max clock speed, revision, and status. Use the Verbose option for extra details. tags:cpu,hardware
Created: 2018-12-02
Modified: 2018-12-17
Creator: Ton de Vreede
Downloads: 127

Show AD user and manager details 1.1.7

This script displays a user's Name, Company, Title, Office, Office Phone Number, Mobile Phone Number and E-Mail Address if they exist in AD, as well as those same details for their Manager. Requires the ActiveDirectory PowerShell module loaded on machine this is be exected from. Created by Rory Monaghan. tags:Active Directory,User Details
Created: 2018-11-26
Modified: 2018-11-27
Creator: Rory.Monaghan
Downloads: 129

Validate protection for speculative execution side-channel vulnerabilities 2.2.6

This SBA confirms whether protection against these vulnerabilities have been enabled on the target computer. For more infomation: https://support.microsoft.com/en-us/help/4072698/ tags:security, powershell, Intel, vulnerabilities, Meltdown, Spectre
Created: 2018-01-04
Modified: 2018-01-11
Creator: Rotem Agmon
Downloads: 96

Enable protection for speculative execution side-channel vulnerabilities 2.2.15

Adds the required registry keys to enable the mitigations on the target computer. Requires the relevant Microsoft patch installed on the target computer. For more inforrmation: https://support.microsoft.com/en-us/help/4072698 tags:security, powershell, Intel, vulnerabilities, Meltdown, Spectre
Created: 2018-01-04
Modified: 2018-01-11
Creator: Rotem Agmon
Downloads: 58